Slowness with *.atheer.com and APIs
Incident Report for Atheer Inc
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 23:34 UTC
Investigating
We are investigating slow response times on *.atheer.com and associated APIs
Posted Jun 03, 2021 - 23:33 UTC